AW: [Allegro] "avanti"-Prozess beendet sich von selbst? (Linux)

Fischer, Thomas fischer at sub.uni-goettingen.de
Don Aug 26 08:47:02 CEST 2010


Hallo Herr Eversberg,

bei uns läuft der Avanti auf SuSE Linux 10.3 (?) ohne Probleme, nur bei der Logrotation wird er per SIGHUP neu gestartet. Ich könnte mir nur vorstellen, dass ein Cron-Job da regelmäßig aufräumt.

Mit freundlichen Grüßen
Thomas Fischer


> -----Ursprüngliche Nachricht-----
> Von: allegro-bounces at biblio.tu-bs.de
> [mailto:allegro-bounces at biblio.tu-bs.de] Im Auftrag von
> Bernhard Eversberg
> Gesendet: Donnerstag, 26. August 2010 08:13
> An: Allegro-C Diskussionsliste
> Betreff: [Allegro] "avanti"-Prozess beendet sich von selbst? (Linux)
>
>
> Ein Linux-Anwender schrieb mir direkt:
>
> "... fällt mir auf, dass der Avanti-Server ohne ersichtlichen Grund
>   beendet wird. Zu dem Zweck habe ich ein Startskript erstellt,
>   dass nach jeweils 5 Minuten aus der pid-datei die ProzessID
>   ausliest und bei Bedarf den Prozess neu startet.
>
>   Dazu ein Auszug aus dem Avanti-Log:
>
>   [2010-08-21 16:55:01]   (WARN) avanti started from /root
>   [2010-08-21 16:55:01]   (NOTE) avanti server av-x v28.8.2
> listening on port 4949 <at avanti.c, line 280>
>   [2010-08-21 16:56:43]   (NOTE) avanti server shutting down
> <at avanti.c, line 287>
>   [2010-08-21 17:00:01]   (WARN) avanti started from /root
>   [2010-08-21 17:00:01]   (NOTE) avanti server av-x v28.8.2
> listening on port 4949 <at avanti.c, line 280>
>
>   Als Basis nutzen wir RedHat 5.3. Leider war es mir bislang nicht
>   möglich den Grund für die Prozessbeendigung herauszufinden."
>
>
> Hat dazu jemand eine Idee?
>
> B.E.
>