[Allegro] cat.api, Zugangsnummer

Bernhard Eversberg ev at biblio.tu-bs.de
Don Aug 19 15:19:10 CEST 2010


Thomas Berger schrieb:

>> NUR darum ging's mir, ganz konkret, damit ich das dann einsetzen kann,
>> ohne noch sonstiges Drumrum rezipieren zu müssen, so nutzvoll und
>> sinnreich das auch für andere Zwecke sein mag.
> 
> In meiner letzten Mail habe ich nur den Schrott zitiert, der in der
> aktuellen cat.api steht, und keinen Verbesserungsvorschlag gemacht,
> das haben Sie gemerkt?
> 
Seufz, ja was denn sonst. Ich bin noch dabei, diese Stelle jetzt mal
wirklich in Ordnung zu bringen. Was ICH mir vorgestellt hatte,
anscheinend Ihrer Meinung nach unsinnig, hatte ich immerhin konkret
verifiziert und es klappte.

> 
>> Aber welche ZgNummern GANZ KONKRET (mit Beispielen) nicht richtig
>> verarbeitet würden, haben Sie immer noch nicht geschrieben.
> 
> Wenn Sie im Rahmen der Vorbehandlung ein "Z" am Anfang eliminieren,
> usw. usw.

ganz konkret meinen Sie also, wenn eine Bibliothek sowohl Nummern ohne
ALSO AUCH welche mit Z am Anfang hat. OK. Ich hatte gedacht, Sie meinen,
wenn die Bearbeiter mal ein Z davor eingeben und mal nicht, dann sollte
es so laufen, als ob sie keins eingeben, es wird aber eins davorgesetzt,
also steht da immer genau eins. Und das, dachte ich, sollte so sein, und
so klappte das mit meinen Zeilen.
Geben Sie Beispiele, dann gibt's kein Mißverständnis.

Aber haben Sie eigentlich gemerkt, daß Ihre Zeile

#u1 +# i4,Z y0 p{"Z"} b1 dzn P>Z Azn        #uzn setzen wg. Prefix

nicht klappen kann, weil das "Z" gar nicht zum Bestandteil von #uzn
wird? Dazu müßte es p"Z" lauten, und dann würde es sofort wieder 
weggenommen. Haben Sie Ihre Reparatur wirklich ausprobiert?

Hilfreich wäre ein Kommentar, der zeigen würde, was genau hier
passieren soll mit ganz konkreten ZgNr.

B.E.