[Allegro] Probleme beim z39.50 Export - Datensatz wird nicht geliefert

Thomas Berger ThB at Gymel.com
Die Apr 29 18:04:41 CEST 2008


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hallo Herr Moeller,

|> vielen Dank für Ihre Antwort.
|
|> Leider bringen die Logs diese3 Fehlermeldung nicht, sondern ich bekomme
|> nur folgendes gesendet:
|> ### 00000nM2.01200024

also fehlt bereits das letzte Zeichen aus dem MAB-Header

|
|> Keine Fehlermeldung, nichts weiter, er zeigt mir sogar an, dass er die
|> z-mab2.apr benutzt, wie ich es von ihm will. Die Datei ist in allen
|> Datenbanken gleich und bei den Anderen klappt es auch.

in z-mab2.apr:

#t{ "### 00000" }
~  Pos. 0-4 : Laenge des Satzes. Wird nicht ermittelt
~  Pos. 5     Status (n=neu, c=corrigiert, p=provisorisch),
~       6-9   M2.0 (konstant)
~       10    Indikatorlaenge '1'
~       11    Teilfeldkennungslaenge '2'
~       12-16 Datenanfangsadresse "00024" (konstant)
~       17-22 Blanks (z.Z. ungenutzte Bytes)

#t { "nM2.01200024      " }

~  Pos.23 Satztyp  (h oder u)
#hi +#99x p"u" e1 #zz 0
#00 +#99x c"+" p"u" e1 #zz 0
#09 +#99x c"+" p"u" e1 #zz 0
#t{ "h" }
#99x
#t{ C &0 }




|> Gibt es vielleicht noch weitere Ideen? (Könnte da jetzt eine apt fehlen?)

eine fehlende .apt wuerde in der Avanti-Log-Datei gemeldet werden.

Ich habe keine Erklaerung dafuer, wie das "h" etwa verloren gehen
koennte, ausser in exakt diesen z-mab2.apr fehlen "#zz 0" oder
es gibt andere Modifikationen gegenueber den funktionierenden
Versionen.

viele Gruesse
Thomas Berger
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3-nr1 (Windows XP)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iQCVAwUBSBdHGWITJZieluOzAQIBzgQAn/n9oDLbnpLP+XreGGyNpzle04h3CW2Z
H4Uf03J+59GhwChkZe5VZx2e4h2zwIO+aRInq1/kCLCxciwuPtCICOcyfotnF5bP
UI34Br6BGJh5onArXBjahmm1M1IOpqDqIdyh9BS1bJwb+vqR+PptYJGqWwJVQgWO
Bkw7eZvOl+U=
=Jd/0
-----END PGP SIGNATURE-----