[Allegro] Index und SGF-Fragen

Robert Fischer rfb at blinx.de
Don Mai 17 11:36:39 CEST 2007


Hallo Frau Panski, lieber Herr Eversberg,

Das habe ich mal gerade versucht, nachzumachen. Bei mir allerdings auf
C:\allegro und habe gewählt:
Datenbank ganz neu aufbauen.

Hat funktioniert.
Unterschiede in der ORG.BAT:
Bei mir alles auf C:\allegro und der erste Aufruf mit -f70

Diese Dinge fallen mir immer wieder bei Index-Problemen ein:
Plattenplatz
konventioneller Arbeitsspeicher
Netzperfomance

Ich erneuere Indexe _immer_ lokal, nie im Netz.

Jetzt aber noch was anderes (in dem Zusammenhang).

Nun wollte ich nochmal das, was aus Frau Panskis ORG.BAT ersichtlich
ist, nachmachen:

Index erneuern mit -fi0

Da wurde dann gefragt, was mit den A1D-Dateien werden soll.

Naja, da habe ich auf Abbruch geklickt und dann a99 regulär beendet.

Jetzt lässt sich die DB nicht problemlos neu öffnen, es kommt die Meldung:

Open anyway?
Momentan kein Zugang wegen Wartung.

Ich glaube, die SGF sollte bei einem Abbruch der Reorganisation nicht übrig
bleiben.

Da steht der weniger Kundige vorm Tore.
Oder er schlägt nach, aber dazu muss er das dann auch dürfen, also access >4
haben.

Dazu habe ich dann auch mal probiert, wie die Auswirkungen eines willkürlich
gesetzten SGF sind.

Ich hätte jetzt vermutet, dass sich keine Datensätze speichern lassen.
Das Programm scheint sich aber um eine nach dem Starten vom Admin gesetzte
SGF nicht zu kümmern.

Wundert sich
Mit freundlichen Grüßen
Robert Fischer Berlin
rfb at blinx.de