[Allegro] index-problem

Thomas Berger ThB at Gymel.com
Mon Apr 23 20:52:56 CEST 2007


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hallo Herr Lehmann,

> eine selbstantwort....
> in dem betreffenden fall, den man in der werkstatt besser beobachten
> konnte, als vorOrt, hat sich ein datensatz ab der stelle 1000 als
> solcher erwiesen:
> 
> 1234500 99n_mit_Inhalt
> 1-5 sind die steuerzeichen
> #00 mit dritter leerer Stelle, die Kategorie ist OHNE Inhalt!
> 
> wohl ein beliebter Punkt, an dem der Indexvorgang zu Fall geht.

Leere Kategorien sind beliebte Punkte fuer Entgleisungen,
wie auch generell Arbeitstexte die leer sind.


> warum ist das so?
> 
> Hat dafür jemand ein Antwort?
> Muß eine Kategorie einen Inhalt haben? lautgedacht, ich denke: ja! 
> Warum? Weil die Kategorie auch zuEnde sein muß, und zwar mit dem
> Zeichen hex00...
> tja, bleibt mir die Frage, wie bekommen die Kollegen einen solchen
> Datensatz hin?

Schon vor vielen Versionen waren in PRESTO Luecken geschlossen
worden, die tendenziell leere Kategorien erlaubten (im #b-Editor-
Fenster m.W.)

Bis vor ganz wenigen Versionen war es allerdings so, dass ausgerechnet
#00 (also die spezielle, erste in der CFG erwaehnte) Kategorie leer
werden konnte: Man konnte dann u.U. sogar noch eine zweite #00
eingeben und sah die erste gar nicht.

Also: In Altdaten haeufiger zu beobachten, mit aktuellen Versionen
eigentlich nicht mehr produzierbar.

viele Gruesse
Thomas Berger

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3-nr1 (Windows XP)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGLQCIhKFJT0F1FsoRAnT4AJ9TDqyA7Rh3EyfALzkhMqRhHK0vugCePPMz
GFo3UY+FOmaarqYOrBliINc=
=0EMG
-----END PGP SIGNATURE-----