AW: AW: AW: [Allegro] Zeichen "&" in Hyperlink per Flex

Liebmann, Sabine Liebmann at bbf.dipf.de
Mon Apr 23 09:56:54 CEST 2007


Liebe Frau Koczian,
> -----Ursprüngliche Nachricht-----
> Von: allegro-bounces at biblio.tu-bs.de [mailto:allegro-bounces at biblio.tu-bs.de] Im
> Auftrag von Sibylle Koczian
> Gesendet: Freitag, 20. April 2007 16:13
> An: Allegro-C Diskussionsliste
> Betreff: Re: AW: AW: [Allegro] Zeichen "&" in Hyperlink per Flex
> 
> Liebe Frau Liebmann,
> 
> "Liebmann, Sabine" <Liebmann at bbf.dipf.de> schrieb:
> > Liebe Frau Koczian, liebe Liste,
> > auch bei mir wird winstart.flx gestartet. Nach dem Einfügen Ihrer drei
> Programmzeilen erscheint die Meldung:
> > "httpwww.bbf.dipf.de/cgi-opac/bil.pl?t_direct=x" konnte nicht gefunden werden ...
> >
> 
> das kann ich leider nicht reproduzieren - irgendwo scheint bei Ihnen das "://" hinter
> dem "http" verschluckt zu werden, fragt sich bloß, wo. Kommt die Meldung von A99
> und der Browser geht gar nicht erst auf, oder kommt sie vom Browser? Und heißt
> "auch in der Demo-Datenbank ohne Erfolg getestet", dass bei den dortigen URLs
> die gleiche Meldung kommt (die enthalten ja alle kein &)? Interessant wäre das,
> weil wir dann wohl unterschiedliche Umcodierungen bei Ihnen und bei mir
> ausschließen könnten.
> 
> Wenn Sie hinter die Zeile "var #ucc..." den Befehl "message" einfügen, was wird
> dann angezeigt? Es müsste so aussehen (und tut es bei mir auch):
> 
> http://"www.bbf.dipf.de/cgi-opac/bil.pl?t%5Fdirect=x&f%5FIDN=09175580"
> 
> Oder mit dem "_" statt %5F, je nachdem, was in Ihrem Datensatz steht. Bei mir
> wird der Unterstrich umgewandelt, wenn ich die URL in A99 im Schreibfeld
> eingebe.
> 
> Ganz blöde, banale Frage: haben Sie die Ergänzungs-Zeilen aus meiner Mail
> kopiert oder abgeschrieben? Im letzteren Fall wäre natürlich auch ein simpler
> Tippfehler nicht völlig auszuschließen und in dieser Ansammlung von
> unterschiedlichen Anführungszeichen leicht zu übersehen. Hier kommt es auf die
> Zeile mit dem "var #ucc..." an.
Ich habe die Ergänzungs-Zeilen kopiert, aber  leider hat sich durch den Zeilenumbruch ein fehlendes Leerzeichen eingeschlichen :-(
Mit der veränderten winstart.flx  funktioniert der Hyperlink auch in der Demo-Datenbank.
Vielen herzlichen Dank für Ihren Tipp und Mühe beim Testen.
Viele Grüße,
Sabine Liebmann