[Allegro] Link aus #8e geht nicht immer

Sibylle Koczian Sibylle.Koczian at t-online.de
Fre Apr 6 11:21:04 CEST 2007


Lieber Herr Berger, 

Am Mittwoch, den 04.04.2007, 21:20 +0200 schrieb Thomas Berger:
> Das hat nichts mit dem jeweiligen Browser zu tun, die Flips
> werden nicht ausgeloest: Die eckigen Klammern sind Bestandteil
> des darzustellenden und anzuklickenden Textes, demzufolge ist
> die verbindende Variable wie folgt belegt:
> 
> #uY1[Publisher description]
> 
> So etwas kann nie funktionieren, weil a99 die eckigen Klammern
> als alternative Begrenzer des darzustellenden Textes auffasst,
> es wird beim Klick erfolglos versucht, irgendeine #uY-Variable mit
> Inhalt "Publisher description" ohne eckige Klammern zu finden.
> 
> Als allgemeines a99-Problem ist es eklig (fast unloesbar, wenn
> man Bandzaehlungen als Link funktionieren lassen moechte, denn
> hier sind Erfassungen ohne eckige Klammern, komplett in eckigen
> Klammern und auch partiell in eckigen Klammern legal), im
> konkreten Fall gibt es jedoch keinen Grund, die Linktexte in
> eckigen Klammern zu erfassen (es gibt m.W. auch keine
> Praezedenzfaelle).
> 

Ihr Hinweis auf Bandzählungen hat mich daran erinnert, dass ich dieses
Problem auch schon gesehen (und aus Faulheit in meinen Datenbanken nie
gelöst) habe. Präzedenzfälle gibt es in der Demo-Datenbank; in den
Daten, mit denen ich im Augenblick zu tun habe, hoffentlich nicht.
Notfalls müssten eckige Klammern an dieser Stelle halt beim Import
weggeworfen werden.

Dank und Gruß,
Koczian