[Allegro] Link aus #8e geht nicht immer

Thomas Berger ThB at Gymel.com
Mit Apr 4 21:20:53 CEST 2007


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Liebe Frau Koczian, liebe Liste,

> Ohne eckige Klammern funktionieren die Links, mit eckigen Klammern
> tun sie nicht.
> 
> Jedenfalls nicht mit Firefox, den IE grabe ich aus den Tiefen meines
> Rechners nur aus, wenn es unbedingt sein muss.

Das hat nichts mit dem jeweiligen Browser zu tun, die Flips
werden nicht ausgeloest: Die eckigen Klammern sind Bestandteil
des darzustellenden und anzuklickenden Textes, demzufolge ist
die verbindende Variable wie folgt belegt:

#uY1[Publisher description]

So etwas kann nie funktionieren, weil a99 die eckigen Klammern
als alternative Begrenzer des darzustellenden Textes auffasst,
es wird beim Klick erfolglos versucht, irgendeine #uY-Variable mit
Inhalt "Publisher description" ohne eckige Klammern zu finden.

Als allgemeines a99-Problem ist es eklig (fast unloesbar, wenn
man Bandzaehlungen als Link funktionieren lassen moechte, denn
hier sind Erfassungen ohne eckige Klammern, komplett in eckigen
Klammern und auch partiell in eckigen Klammern legal), im
konkreten Fall gibt es jedoch keinen Grund, die Linktexte in
eckigen Klammern zu erfassen (es gibt m.W. auch keine
Praezedenzfaelle).

viele Gruesse
Thomas Berger
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3-nr1 (Windows XP)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFGE/qVhKFJT0F1FsoRAq5jAJ9S1NmCqnzfD5iMi7O3OnozvVD5kQCggUKD
/CgjF9eCdnCRF2G7Yw/hD9g=
=SUCM
-----END PGP SIGNATURE-----